Compass Unavailable
Incident Report for Seton Hall University
Resolved
Access to Compass has been restored.
Posted Mar 02, 2021 - 14:13 EST
Investigating
Compass, the university's student success management system, is temporarily unavailable.
Posted Mar 02, 2021 - 14:08 EST
This incident affected: Compass.