Blog Platform Maintenance: Tuesday, May 19

Scheduled for May 19, 06:00 EDT  -  May 22, 06:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 30, 2026 - 14:24 EDT

Scheduled

To improve reliability, security, and overall performance, blogs.shu.edu and eportfolio.shu.edu will be migrated to a new hosting environment beginning May 19, with an estimated three-day maintenance window.

During this time, all sites will remain publicly accessible, but authoring will be unavailable. Users will not be able to log in or make updates, and any attempted changes during this period will not be saved.

Learn more: https://servicedesk.shu.edu/space/PUBLICKBA/4405166102/WordPress+Blogging+Platform
Posted Apr 30, 2026 - 14:24 EDT
This scheduled maintenance affects: WordPress Blog Service.