The Department of Information Technology has identified a temporary workaround for the issue affecting access to Banner Admin pages in Google Chrome and Mozilla Firefox. While we continue to work with Ellucian on a permanent resolution, instructions for restoring access are available in the knowledgebase: https://servicedesk.shu.edu/space/PUBLICKBA/3903291396/Resolve+Banner+Admin+Access+Errors+in+Chrome
Please note: AppStream remains unaffected, as it uses an older version of Chrome that is not impacted by the recent browser updates.
Posted Oct 31, 2025 - 13:40 EDT
Update
Ellucian has confirmed that the issue remains under review. AppStream remains unaffected, as it uses an older version of Chrome. Users running the latest version of Chrome or Firefox may continue to experience issues accessing Banner Admin.
The Department of Information Technology is continuing to work with Ellucian to identify a solution. Further updates will be shared as soon as more information becomes available.
Posted Oct 31, 2025 - 11:40 EDT
Identified
The Department of Information Technology has been alerted that a recent Chrome and Firefox update is interrupting access to Banner Admin pages. We are working with Ellucian to identify a workaround and will provide an update as soon as possible.