Printing Issues at South Orange and Law School

Incident Report for Seton Hall University

Resolved

Printing services at the South Orange and Law School campuses have been restored. The Division of Information Technology continues to investigate the cause of the issue.
Posted Aug 24, 2026 - 16:53 EDT

Investigating

The Division of Information Technology is aware of an issue affecting some printers at the South Orange and Law School campuses. Users may be unable to print from affected devices.

We are actively working to resolve the issue and will provide an update as more information becomes available.
Posted Aug 24, 2026 - 11:48 EDT
This incident affected: Blueprint.