Touchnet Service Disruption

Incident Report for Seton Hall University

Resolved

The issue impacting students' ability to view accurate account balances and complete transactions in Touchnet has been resolved.

If you continue to experience any issues, please contact the Technology Service Desk for assistance.
Posted Mar 27, 2026 - 22:22 EDT

Investigating

The Department of Information Technology is investigating an issue impacting students' ability to view accurate account balances and complete transactions in Touchnet.

At this time, student balances may appear incorrect, not display, or not properly post to Banner. As a result, students and authorized users may be unable to accurately view account details or manage payments.

Updates will be provided as more information becomes available. We apologize for the inconvenience and appreciate your patience.
Posted Mar 27, 2026 - 16:28 EDT
This incident affected: Touchnet.