Microsoft Outlook for Web
Incident Report for Seton Hall University
Resolved
A recent change by Microsoft resulted in users experiencing authentication failures. Microsoft completed the rollback of the impacting change successfully and users should now be able to successfully sign in to Outlook on the web.
Posted May 13, 2020 - 16:01 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 13, 2020 - 15:47 EDT
Investigating
Outlook Web Access is experiencing an intermittent disruption in service. Some users are experiencing an issue accessing Outlook Online in a web browser. Microsoft is aware of the issue and working to resolve it as soon as possible.

Access through the Outlook desktop application and phone apps are working properly.
Posted May 13, 2020 - 14:37 EDT
This incident affected: Microsoft Office 365.